CCNP 筆記本

2009 年 06 月 09 日

CCNP-BSCI Module 03 OSPF (1)

Filed under: CCNP-BSCI Module 03 — nkongkimo @ 13:07:40

OSPF特性

1.IGP:Link-State Protocol
2.Classless 支援VLSM
3.AD值為110
   Cost=10的8次方/BW
4.收斂快,利用SPF演算法算出最佳路徑,利DR & BDR來速收斂。
5.在LAN的環境只跟Adjacency router(DR & BDR)交換路由資訊。
6.利用LSA(link state adj.)封包來建立完整Topology,但要在同一個AS裡,並每一個Router都有相同的LSDB(路由資料庫)。
7.利用SPF演算法算出最佳路徑。
8.3張表(鄰居表、拓樸表(database)、路由表)
9.使用SPF演算法,不會有迴圈。
10.採用階層式的架構設計,使網路更方便管理。
     分為2層-(1)Backbone(Transit):負責轉送其他區域封包的區域。代號為AS 0。
                   (2)Unbackbone(Regular):自己獨立的AS區域,代碼從1開始。
11.以介面來宣告區域,不看整個Router再哪一個區域。
12.只有ABR & ASBR可以做路由資訊的摘要。
13.Unbackbone的router若要跨Area傳輸需要透過Backbone Area,無法直接傳輸。

 

OSPF & EIGRP 的比較

  EIGRP OSPF
Hello interval 大BW=5sec
小BW=60sec
大BW=10sec
小BW=30sec
Hold-Time
(Dead-interval)
Hello*3(sec) Hello*4(sec)
Multucast Address 224.0.0.10 224.0.0.5(all ospf router)
224.0.0.6(all ospf DR router)
Form Adjacency 與Hello Interval&Hold Time無關
AS、K值、Subnet相同即可。
Hello、Interval&Hold Time、AS、Subnet必須相同。
路由改變時 利用Partial updates 不做週期更新 只要更新會通知整各topology的router
Timer Distance-Vactor timer
預設Hello Interval的3倍時間
Link-state timer
1.MaxAge=60min
2.Refresh=30min

 

OSPF & EIGRP Packets Type的比較

Type EIGRP OSPF 用途
1 Hello Hello 尋找、建立鄰居關係,並當作keepalive的功能
2 Update DBD(Datebase Description)
or
DDP(Datebase Desctiption Packet)
交換Link-State DataBase的摘要,並比對路由的資訊是否需要更新。
3 Query LSR(Link State Request) Router需要請求特定的封包時,會送出此訊息
4 Reply LSU(Link State Update) 對路由的狀態送出更新的資訊。
5 ACK ACK or LSACK 確認的訊息

*OSPF的封包中DBD / LSR / LSU 屬於可靠性傳輸(需要回覆ACK)。

OSPF 的 Area

1.Backbone(Transit):
*負責轉送其他Area的資料
*Area=0
*需要有延續性

2.Unbackbone(Regular):
*都要接到Backbone再轉送到其他Area區域,無法直接傳輸。
*分為5大區域:

區域 定義
(1)Normal(Regular) Area:標準的區域

*RFC定義
*收Type1~5,預設都是這種區域。
show ip route

(2)Stub Area:末梢區域

*RFC定義
*不收Type5,只收Type1~4,由ABR Inject Default Route給Stub Area 的Router。
*只要宣告自己為Stub Area ABR會自動送給他Default rout(Type 3 ,Default Cost=1) 。
*Stub Area 裡面的Router都要設定為Stub Router才會形成Adjacence的關係。
*在Stub Area裡面不行有ASBR的存在,也一定不可設定為Area 0。
*不可成為Transit Area。
*在路由表只會看到O*IA。

Stub Area設定方法:

Stub Area 範例與Show
(3)Not-So-Stubby Area(NSSA)

*運作類似Stub area
*RFC定義
*簡單來說就是Stub Area有ASBR Router的存在。(Stub area with "ASBR")
*主要用於不支援OSPF的AS要送資料到OSPF的AS使用。
*若要送到其他Area會由NSSA Area的ABR轉換成Type 5送出。
*不收Type5,只收Type1~4和7,由ABR 手動設定 Default Route給NSSA Area 的Router。

NSSA設定方法:

Not-So-Stubby Area(NSSA)範例
(4)Totally Stubby Area

*Cisco定義
*只收Type1、2,由ABR Inject Default Route給Totally Stub Area 的Router。
*只要宣告自己為Totally Stubby Area ABR會自動送給他Default route(Type 3 ,Default Cost=1) 。
*可手動調整Cost值,越小越好。
*在路由表只會看到O*IA
*與Stub Area的狀況類似。

Totally Stubby Area 設定的方式:
 

*ABR會自動濾掉Type3、4

Totally Stubby Area範例
show ip route
(5)NSSA Totally Stubby Area:

*Cisco定義
*運作與NSSA一樣。
*簡單來說就是Stub Area有ASBR Router的存在。(Stub area with "ASBR")
*主要用於不支援OSPF的就AS要送資料到OSPF的AS使用。
*若要送到其他Area會由NSSA Totally Atubby Area的ABR轉換成Type 5送出。
*只收Type1、2和7,由ABR 手動設定 Default Route給NSSA Totally Stubby Area 的Router。

 

OSPF Router 的種類

1.Backbone Router:所有的介面都在Area 0區域內,較特殊的router。
2.Internal Router:所有的介面都在同一個區域內。
3.ABR Router:跨在2個OSPF的區域中間的Router,可以做路由摘要。
4.ASBR Router:跨在2個不同路由協定的Router,可以做路由摘要。

 

OSPF Adjacencies 關係

*利用Hello(LSA)來建立Adjacencies的關係,當都建立完成後叫做Full Adjacencies。
*在Multi-Access架構中,利用DR/BDR來加速收斂。
*224.0.0.5 叫做All OSPF Router  (所有的OSPF router都會接收)
*224.0.0.6叫做All OSPF DR Router  (只有DR&BDR才會接收)

OSPF的計算方式和LSA運作方式

1.LSA會依尋split horizon規則,不會把由鄰居收到的路由資訊回傳。
2.LAS的運作方式

OSPF封包Header的類型

Type 1: Hello Packets 細部內容
Type 2: DBD(DB 描述) Packets 細部內容
Type 3: LSR(Link State Request) Packets 細部內容
Type 4: LSU(Link State Update) Packets 細部內容

註:詳細資訊可以參考 "OSPF Packet Type- LSU(LSA) Packet 的種類"
Type 5: LSACK(Link State ACK) Packets 細部內容

OSPF 建立連結的過程

Step1:
*先利用Hello的方式找鄰居
*狀態種類:

種類 定義
Down state 還沒有收到Hello的狀態
Init state: 收到Hello封包但未加入對方鄰居表的狀態
Two-Way 雙方建立鄰居關係的狀態

Step2:
*選擇DR / BDR的角色
*在Multi-Access的環境才需要,在Point-to-Point的環境不需要此程序直接成為Exchange state的狀態。
*狀態種類:

種類 定義
Exstart State 進入DR / BDR的選舉
Exchange State 完成DR / BDR選舉的程序,由Router-ID大的成為DR

Step3:
*確認路由資訊的完整性
*狀態種類:

種類 定義
Loading State 送出向DR需求的特定資訊的封包(LSU),就會進入此狀態
Full State 當DR把需要的資訊送給Router,並完成路由DB收斂後,就形成Full State的狀態

OSPF 溝通的狀態

DR/BDR selecte

1.選擇DR / BDR的架構
(1)Unbroadcast 的架構: 不支援廣播&群播,需要手動指定DR位址。
(2)Multi-Access的架構(表示網段裡面有3顆router以上): 支援廣播&群播,自動會選擇DR/BDR。
2.選擇順序:
(1)Priority最高的,預設值=1(0~255),每一個介面的priority可以不同。
(2)Router ID 大的成為DR
3.不具強制性,DR / BDR選好就不會變了,除非設備或topology重置。
4.DR/BDR 依網段去選擇的,所以不同網段Router可能是DR or BDR。
5.設定Priority值
6.Router 的角色:
(1)DR(Designated Router):委任路由器。
(2)BDR(Backup Designated Router):被援委任路由器。
(3)DROther:不是DR or BDR的Router。
7.DR使用的狀況:
(1)在FULL-Mesh的狀況下,效能最佳都做DR。
(2)在NBMA的架構下,當Hub的Router都當作DR。

 

LSA Sequence Number

*由0x80000001開始到0x7FFFFFFF,由負的開始到正的。每30分鐘reflash一次。

Config OSPF

 
EXP:

建立穩定的連線

 

Show的觀察

1.show ip ospf

image

2.show ip ospf neighbor
 
3.sh ip ospf neighbor detail
 
4.show ip route ospf
 
5.show ip ospf interface f0/0
6.debug ip ospf packet
7.show ip ospf database
*DataBase會自動以Area來區分
*OSPF路徑選擇的方法為LSA小的優先選擇,不管Cost值。
8.show ip ospf protocol
9.debug ip ospf hello

 

OSPF 3大網路類型

類型 內容 運用架構
Point-to-point *不需要選出DR/BDR
*利用Multicast OSPF Hello建立鄰居database
*容易建立鄰居關係
*架構簡單就只是點對點
PPP
HDLC
Broadcast
multiaccess
*需要選出DR/BDR
*利用Multicast OSPF Hello建立鄰居database
*在一個網路裡面超過2顆router的情況
*此架構本身就支援Broadcast / Multicast
LAN
Token Ring

Full-mesh
Partial-mesh

Nonbroadcast multiaccess
(NBMA)
*需要選出DR/BDR
*要用Unicast OSPF Hello建立鄰居表
*需要把Multicast轉成Unicast,所以鄰居需要手動建立。
*在一個網段上可有2個一上的Router
*不支援Broadcast的傳送
F.R
ATM
X.25

Full-mesh
Partial-mesh

 

Nonbroadcast Multiaccess (NBMA)的5種網路類型

類型 內容 架構
1.Nonbroadcast *需要選出DR/BDR
*要用Unicast OSPF Hello建立鄰居表
*需要把Multicast轉成Unicast,所以鄰居需要手動建立。

*傳統的NBMA
*不支援Broadcast的傳送
F.R
ATM
X.25
2.Point-to-Multipoint *不需要選出DR/BDR
*要用Multicast OSPF Hello建立鄰居表
*RFC2328定義
*都在同一個網段上
*使用Multicast OSPF Hello去自動建立鄰居表

Hub-and-Spoke
Partial-mesh
3.Point-to-Multipoint  
   Nonbroadcast
*Cisco專屬
*不需要選出DR/BDR
*要用Unicast OSPF Hello建立鄰居表
*點對多點,集中點需要變成DR
*不支援Broadcast的傳送
*需要把Multicast轉成Unicast,所以鄰居需要手動建立。
 
4.Broadcast *Cisco專屬
*需要選出DR/BDR
*要用Multicast OSPF Hello建立鄰居表
*須要Router把Broadcast的封包在每一個VC上複製在用Unicast的方式送出,來模擬Broascast的功能。
 
5.Point-to-Point *Cisco專屬
*不需要選出DR/BDR
*要用Multicast OSPF Hello建立鄰居表
*容易建立鄰居關係
*不同的網段在同一個介面上
*架構簡單就只是點對點
LAN
WAN

 

OSPF & EIGRP Hello的比較

OSPF Hello       EIGRP Hello    
Network type Hello interval Dead interval Network type Hello intercal Dead interval
Point-to-Point 10 sec 40 sec LAN 5 sec 15 sec
Broadcast 10 sec 40 sec WAN
(大BW)
5 sec 15 sec
NBMA 30 sec 120 sec WAN
(小BW)
60 sec 180 sec

 

NBMA(Nonbroadcast Multiaccess)鄰居的設定

1.NBMA Nonbroadcast 設定方式
 image
(1)neighbor只需要在DR的router指令即可
(2)neighbor後面的priority表示給對方的pri數值(0表示不競選DR)
(3)使用show ip ospf neighbor觀察競選的狀況
image
2.NBMA Point-to-Multipoint 設定方式
大部分用在hub-and-spoke
image
image
image 
3.Cisco’s Point-to-Multipoint Non-broadcaat 設定方法
*不支援Multicast傳送
*不需要選擇DR / BDR
*需要手動指定鄰居

R1(config-if)#ip ospf network point-to-multipoint non-broadcast
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#neighbor 192.168.1.1 cost 10 (需要手動設定鄰居)
R1(config-router)#neighbor 192.168.1.2 cost 20 (需要手動設定鄰居)

4.F.R上面用Sub-interface的模式:

(1).Point-to-Point Subinterface 設定方法
*不需要DR/BDR
*利用Multicast OSPF Hello建立鄰居database

2.Multipoint Subinterface 設定方法

*需要選擇DR/BDR
*利用Unicast OSPF Hello建立鄰居database,所以需要手動設定鄰居。

4.Cisco’s Broadcast mode
*需要選出DR/BDR
*要用Multicast OSPF Hello建立鄰居表
*需要在Full-Mesh的架構下

R3(config-if)#ip ospf network broadcast (宣告為Broadcast)
R3(config-router)#network 192.168.1.0 0.0.0.255 area 0 (宣告網段)
5.Cisco’s Point-to-Point mode
*不需要選出DR/BDR
*要用Multicast OSPF Hello建立鄰居表
*需要在Full-Mesh的架構下

R3(config)#interface serial 0/0.1 point-to-point (宣告為P2P介面)
R3(config-subif)#ip address 3.1.1.2 255.255.255.0
R3(config)#interface serial 0/0.2 point-to-point (宣告為P2P介面)
R3(config-subif)#ip address 4.1.1.2 255.255.255.0
R3(config-router)#network 3.1.1.0 0.0.0.255 area 0 (宣告網段)
R3(config-router)#network 4.1.1.0 0.0.0.255 area 0 (宣告網段)

 

OSPF & EIGRP Authentication Type的比較

  EIGRP OSPF

認證方式

1.Simple password                 

*較不安全,因用明文傳送。

1.Simple password                    

*較不安全,因用明文傳送。

2.MD5 authentication
*較安全,不會把key送出去。
*用key chain去管理key,認證時需告知key ID來進行認證。

2.MD5 authentication
*較安全,不會把key送出去。
*用key chain去管理key,認證時需告知key ID來進行認證。

 

Authentication的方法

1.Simple password Authentication 設定

(1)在介面上設定,範圍較小,只針對介面。

(2)在Area區域內設定,範圍較大,建議使用此方法。
2.MD5Authentication 設定

debug ip ospf
廣告

CCNP-BSCI Module 03 OSPF (2)

Filed under: CCNP-BSCI Module 03 — nkongkimo @ 13:01:49

OSPF Packet Type- LSU(LSA) Packet 的種類

LSU Packet種類 定義

1.Router LSA
(Router Link)

image
  1.描述Router的Links(介面網段)
2.在同一個Area中Flooding,不會跨Area。
3.Link-State ID=RID of the Origination Router(誰送出此LSA的資訊)
4.OSPF Link type:

Link type 描述 Link-ID

1

Point-to-Point interface

Neighboring router ID

2

Transit network(Multiaccess)

IP address of DR  (DR的IP)

3

Stub network

(no ospf neighbor Router)

ip network / subnet number

4

Virtual Link(類似Tunnel)

Neighboring router ID

5.show ip ospf database

 image
6.路由資訊的代號為: O

2.Network LSA
(Network Link)

  1.由DR產生Network LSA。
2.在同一個Area中Flooding,不會跨Area。
3.Show ip ospf database
 
4.路由資訊的代號為: O

3.Network Summary LSA

  1.由ABR產生Type 3封包
2.ABR把Type 1的內容轉成Type 3送到其他區域
3.可以做Summary再送出,預設沒有啟用Summary。
4.Type 3會在整個OSPF Dimain  Flooding。
5.show ip ospf database
 
6.路由資訊的代號為: OIA
4.ASBR Summary LSA
  1.ASBR Router要通知其他Area 1的Router有一個。
2.ABR Router 要把Type 1轉換成Type 4,並告知其他Router在Area 1有ASBR。
3.Type 4會在整個Routing Domain(AS) Flooding。
4.Type 4只用來說明ASBR的router在哪邊的資訊。
5.Type 4由ABR產生。
6.show ip ospf database
 
7.路由資訊的代號為: OIA
5.AS External LSA
  1.Type 5由ASBR產生,在整個Routing Domain Flooding(AS)。
2.Type 5的內容為外部路由的資訊。
3.Link state ID為外部網路的代號。
4.show ip ospf database
 
5.路由資訊的代號為: OE1/ OE2
6.Type 5會在整個AS flooding。
7.NSSA External LSA 1.Type 7由ASBR產生,只在NSSA Domain Flooding。
2.若要送到其他Area會由NSSA Area的ABR轉換成Type 5送出。
3.路由資訊的代號為: ON1/ ON2
 
 

*每一個LSA有"Link-state ID"來辨識並表示該LSA描述了Routing Dimain中那部份的訊息。

*Link-state ID的值會因不同的LSA Type而有不同內容的值。

 

OSPF路由資訊的種類

OSPF 代號種類:

種類 內容
1.O *OSPF Intra-Area Route(在區域內)
*Type 1&2都是用"O"表示。
2.OIA *OSPF Inter-Area Route(在區域與區域之間)
*Type 3&4都是用"OIA"表示。
3.OE1 *OSPF External AS Route(在區域外)
*計算外部成本加計內部成本。
*有多條link時建議使用OE1
4.OE2 *OSPF External AS Route(在區域外)
*計算外部成本,不加計內部成本。
*預設為OE2

OE1 & OE2的區別

 

OSPF Link-State DataBase 的防護機制

*用於LSA瞬間大量建立Adjacence的時候,把一些超額的LSA drop掉。
*建議盡量把adjacence的router變少。

調整OSPF Path Cost

*Cisco預設的成本為 10的8次方/BW(bps)=Cost
*10的8次方就是reference BW
種類 內容
1.修改Bandwidth的參數 *修改介面Bandwidth的參數
2.調整Reference Bandwidth的數字
(建議使用此項目調整)
*預設值為100
*在介面下設定
3.指定每一個介面的cost值 *範圍為1~65535
*較建議使用的方法
 

 

OSPF Virtual Link

*臨時建立用或備援用,無法長期使用
*類似利用Tunnel的方法,把資料都封裝在裡面,用unicast的方式送出去。
*因不是實體連線要盡量降低封包的傳送。
*利用DNA(DoNotAge)的機制來抑止過多的Hello flooding。
使用的情況:

1.連線中斷
2.沒有連續的Area 0 或有2個Area 0的情況:
設定的方法:
範例:
Show的觀察

show ip ospf virtual-link

Route Summarization

1摘要點為ABR & ASBR Router:
*ABR把資料轉成Type 3送進去
*ASBR把資料轉成Type 5送進去
*ABR & ASBR都需要手動設定summary,預設沒有啟動。
2.Summary的好處:
當發生Topology change只影響自己的區域,不會影響到整個OSPF Domain。
3.摘要的方法:
*摘要的內容在路由表中一定要有一筆以上符合摘要的路由資訊。

Example:
*ABR設定方法
*ASBR設定方法
 

OSPF Area Type 類型

1.Standard /Regular Area :
(1)不會自動產生Default Route
(2)以Type 5 Extranal LSA的方式inject
(3)指令: default-infotmation originate [always] / 或加入"always"此參數,需要本身有Default Route or加入"always"此參數。
(4)路由表預設已O*E2出現
 
2.Stub Area /Totally Stubby Area / NSSA Totally stubby Area:
(1)ABR會自動Inject Default Route進去
(2)以Type 3方式Inject
(3)以O*IA方式出現
(4)全部區域的Router都要設定Stub or Totally Stubby

Stub Area (1)只接收Type1~4的LSA封包
(2)只有一個出口的環境
(3)不可以是Area0
(4)不可以有其他路由協定
 image
Totally Stubby Area (1)只接收Type1&2的LSA封包,不收summary 的封包
(2)只有一個出口的環境
(3)不可以是Area0
(4)不可以有其他路由協定
(5)Cisco專屬的區域
(6)只需要在ABR Router設定即可
image
image
NSSA Totally stubby Area

(1)只接收Type1&2&7的LSA封包
(2)只有一個出口的環境
(3)不可以是Area0 
(4)Cisco專屬的區域
(5)只需要在ASBR Router設定即可

(6)ABR(R2)會自動inject  deafult route 給R1

R1#sh ip route

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.20.0 is directly connected, FastEthernet0/0
R    192.168.99.0/24 [120/1] via 192.168.1.2, 00:00:19, FastEthernet0/1
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.3 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, FastEthernet0/1
O*IA  0.0.0.0/0 [110/11] via 172.17.20.1, 00:00:36, FastEthernet0/0

   
3.NSSA Area Type:
(1)預設不會自動產生Default Route
(2)由NSSA ASBR 產生
(3)以Type 7方式送入
(4)預設以O*N2出現
(5)指令:area XX nssa default-information orignate
Example:

在WordPress.com寫網誌.